aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 24 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9cb47d5..77aded9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,16 +11,30 @@
[package]
name = "unicode-width"
-version = "0.1.9"
-authors = ["kwantam <kwantam@gmail.com>", "Manish Goregaokar <manishsmail@gmail.com>"]
-exclude = ["target/*", "Cargo.lock"]
-description = "Determine displayed width of `char` and `str` types\naccording to Unicode Standard Annex #11 rules.\n"
+version = "0.1.10"
+authors = [
+ "kwantam <kwantam@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+]
+exclude = [
+ "target/*",
+ "Cargo.lock",
+]
+description = """
+Determine displayed width of `char` and `str` types
+according to Unicode Standard Annex #11 rules.
+"""
homepage = "https://github.com/unicode-rs/unicode-width"
documentation = "https://unicode-rs.github.io/unicode-width"
readme = "README.md"
-keywords = ["text", "width", "unicode"]
+keywords = [
+ "text",
+ "width",
+ "unicode",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/unicode-rs/unicode-width"
+
[dependencies.compiler_builtins]
version = "0.1"
optional = true
@@ -39,4 +53,8 @@ package = "rustc-std-workspace-std"
bench = []
default = []
no_std = []
-rustc-dep-of-std = ["std", "core", "compiler_builtins"]
+rustc-dep-of-std = [
+ "std",
+ "core",
+ "compiler_builtins",
+]