summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKeiichi Watanabe <keiichiw@chromium.org>2021-03-04 00:15:53 +0900
committerKeiichi Watanabe <keiichiw@chromium.org>2021-03-04 00:17:15 +0900
commit73a86a346836d0329d2862387bc8a81be8a338ca (patch)
treeef9bb7f8b3371f8792c76058d5856cac8bc1cd31 /Cargo.toml
parent6ccc681e7e1808e0d9d2536eb90ef203511ab359 (diff)
parent62fd4ec5a47d1b9cd1ea2c8702228ea216b92686 (diff)
downloadvmm_vhost-73a86a346836d0329d2862387bc8a81be8a338ca.tar.gz
Merge remote-tracking branch 'cros/upstream/master' into HEAD
BUG=none TEST=none Cq-Depend: chrome-internal:3639368, chrome-internal:3639230 Change-Id: Iaa169363f8e4ef933b4775009ad000fdc0ce0da5
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8c676b3..0cd15f7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,16 +1,22 @@
[package]
name = "vhost"
version = "0.1.0"
+keywords = ["vhost", "vhost-user", "virtio", "vdpa"]
+description = "a pure rust library for vdpa, vhost and vhost-user"
authors = ["Liu Jiang <gerry@linux.alibaba.com>"]
repository = "https://github.com/rust-vmm/vhost"
+documentation = "https://docs.rs/vhost"
+readme = "README.md"
license = "Apache-2.0 or BSD-3-Clause"
+edition = "2018"
[features]
default = []
vhost-vsock = []
vhost-kern = ["vm-memory"]
-vhost-user-master = []
-vhost-user-slave = []
+vhost-user = []
+vhost-user-master = ["vhost-user"]
+vhost-user-slave = ["vhost-user"]
[dependencies]
bitflags = ">=1.0.1"
@@ -18,3 +24,6 @@ libc = ">=0.2.39"
vmm-sys-util = ">=0.3.1"
vm-memory = { version = "0.2.0", optional = true }
+
+[dev-dependencies]
+vm-memory = { version = "0.2.0", features=["backend-mmap"] }