summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJorge E. Moreira <jemoreira@google.com>2021-04-15 09:03:39 -0700
committerJorge E. Moreira <jemoreira@google.com>2021-04-15 09:13:33 -0700
commit86868ea15c099f99ed1ddf83d870e1b025d9d53b (patch)
tree56be29b9f4f9f6308a7ce7adb8a77cdf115f1bc6 /Cargo.toml
parent9dc6172cfed4ab25b52a45f3e74dc992b7fb485d (diff)
parent98298cb96972c20e05bffed58861456b48328d43 (diff)
downloadvmm_vhost-86868ea15c099f99ed1ddf83d870e1b025d9d53b.tar.gz
Merge remote-tracking branch 'aosp/upstream-main'
Bug: 185157703 Test: locally with following change Change-Id: Id39b5523128be41f44b551722ffcf325b58dbb58
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..917ea25
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "vmm_vhost"
+version = "0.1.0"
+keywords = ["vhost", "vhost-user", "virtio", "vdpa"]
+description = "a pure rust library for vdpa, vhost and vhost-user"
+authors = ["Liu Jiang <gerry@linux.alibaba.com>"]
+repository = "https://github.com/rust-vmm/vhost"
+documentation = "https://docs.rs/vhost"
+readme = "README.md"
+license = "Apache-2.0 or BSD-3-Clause"
+edition = "2018"
+
+[features]
+default = []
+vhost-vsock = []
+vhost-kern = ["vm-memory"]
+vhost-user = []
+vhost-user-master = ["vhost-user"]
+vhost-user-slave = ["vhost-user"]
+
+[dependencies]
+bitflags = ">=1.0.1"
+libc = ">=0.2.39"
+
+sys_util = { path = "../../../platform/crosvm/sys_util" } # provided by ebuild
+tempfile = { path = "../../../platform/crosvm/tempfile" } # provided by ebuild
+vm-memory = { version = "0.2.0", optional = true }
+
+[dev-dependencies]
+vm-memory = { version = "0.2.0", features=["backend-mmap"] }