summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLiu Jiang <gerry@linux.alibaba.com>2021-02-19 19:21:17 +0800
committerSergio Lopez <slp@sinrega.org>2021-03-01 12:50:56 +0100
commit97421f754d8d38508687926b5045c4ed1bd6c107 (patch)
tree70a5a0dabe8b02522c0d858f2f181a1f5ffd8bd9 /Cargo.toml
parenta7847dcf7def2b750468297e060d0a55be2a7b62 (diff)
downloadvmm_vhost-97421f754d8d38508687926b5045c4ed1bd6c107.tar.gz
Upgrade to rust 2018 edition
Upgrade Cargo.toml to rust edition 2018. Also introduce a helper feature flag "vhost-user" to simplify code. Signed-off-by: Liu Jiang <gerry@linux.alibaba.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8c676b3..b8609f5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,13 +4,15 @@ version = "0.1.0"
authors = ["Liu Jiang <gerry@linux.alibaba.com>"]
repository = "https://github.com/rust-vmm/vhost"
license = "Apache-2.0 or BSD-3-Clause"
+edition = "2018"
[features]
default = []
vhost-vsock = []
vhost-kern = ["vm-memory"]
-vhost-user-master = []
-vhost-user-slave = []
+vhost-user = []
+vhost-user-master = ["vhost-user"]
+vhost-user-slave = ["vhost-user"]
[dependencies]
bitflags = ">=1.0.1"
@@ -18,3 +20,6 @@ libc = ">=0.2.39"
vmm-sys-util = ">=0.3.1"
vm-memory = { version = "0.2.0", optional = true }
+
+[dev-dependencies]
+vm-memory = { version = "0.2.0", features=["backend-mmap"] }