summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLiu Jiang <gerry@linux.alibaba.com>2019-04-03 21:59:49 +0800
committerAndreea Florescu <andreea.florescu15@gmail.com>2020-09-04 17:59:53 +0300
commitbcbbaaabb33dcdcced8b7dc85e615c71df3d3fd3 (patch)
treeefd4c240f9a58a7e46e14f7aa43da6c5c8c34599 /Cargo.toml
parent5d61e36bdac5920b51bfd0649ebd2cef300282a7 (diff)
downloadvmm_vhost-bcbbaaabb33dcdcced8b7dc85e615c71df3d3fd3.tar.gz
Add traits to support vhost backend devices
These interfaces are derived from the firecracker and crosvm projects. They may be extended when enable support of vhost-user protocol. Signed-off-by: Liu Jiang <gerry@linux.alibaba.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 05dd9ea..2eba08a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,4 +5,10 @@ authors = ["Liu Jiang <gerry@linux.alibaba.com>"]
repository = "https://github.com/rust-vmm/vhost"
license = "Apache-2.0 or BSD-3-Clause"
+[features]
+default = []
+vhost-vsock = []
+
[dependencies]
+vmm-sys-util = ">=0.3.1"
+vm-memory = { version = "0.2.0", optional = true }