summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8c676b3..0cd15f7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,16 +1,22 @@
[package]
name = "vhost"
version = "0.1.0"
+keywords = ["vhost", "vhost-user", "virtio", "vdpa"]
+description = "a pure rust library for vdpa, vhost and vhost-user"
authors = ["Liu Jiang <gerry@linux.alibaba.com>"]
repository = "https://github.com/rust-vmm/vhost"
+documentation = "https://docs.rs/vhost"
+readme = "README.md"
license = "Apache-2.0 or BSD-3-Clause"
+edition = "2018"
[features]
default = []
vhost-vsock = []
vhost-kern = ["vm-memory"]
-vhost-user-master = []
-vhost-user-slave = []
+vhost-user = []
+vhost-user-master = ["vhost-user"]
+vhost-user-slave = ["vhost-user"]
[dependencies]
bitflags = ">=1.0.1"
@@ -18,3 +24,6 @@ libc = ">=0.2.39"
vmm-sys-util = ">=0.3.1"
vm-memory = { version = "0.2.0", optional = true }
+
+[dev-dependencies]
+vm-memory = { version = "0.2.0", features=["backend-mmap"] }