aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml112
1 files changed, 87 insertions, 25 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d18af58..c68f39a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,59 +3,121 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "vulkano"
-version = "0.25.0"
-authors = ["Pierre Krieger <pierre.krieger1708@gmail.com>", "The vulkano contributors"]
+version = "0.33.0"
+authors = [
+ "Pierre Krieger <pierre.krieger1708@gmail.com>",
+ "The vulkano contributors",
+]
build = "build.rs"
description = "Safe wrapper for the Vulkan graphics API"
homepage = "https://vulkano.rs"
documentation = "https://docs.rs/vulkano"
-readme = "../README.md"
-keywords = ["vulkan", "bindings", "graphics", "gpu", "rendering"]
+readme = "README.md"
+keywords = [
+ "vulkan",
+ "bindings",
+ "graphics",
+ "gpu",
+ "rendering",
+]
categories = ["rendering::graphics-api"]
license = "MIT/Apache-2.0"
repository = "https://github.com/vulkano-rs/vulkano"
+resolver = "1"
+
+[dependencies.ahash]
+version = "0.8"
+
[dependencies.ash]
-version = "0.33.0"
+version = "^0.37.2"
+
+[dependencies.bytemuck]
+version = "1.9"
[dependencies.crossbeam-queue]
version = "0.3"
-[dependencies.fnv]
-version = "1.0"
-
[dependencies.half]
-version = "1.7"
+version = "2"
+features = ["bytemuck"]
+
+[dependencies.libloading]
+version = "0.7"
-[dependencies.lazy_static]
-version = "1.4"
+[dependencies.once_cell]
+version = "1.17"
[dependencies.parking_lot]
-version = "0.11.1"
+version = "0.12"
features = ["send_guard"]
-[dependencies.shared_library]
-version = "0.1"
+[dependencies.serde]
+version = "1.0"
+optional = true
[dependencies.smallvec]
-version = "1.6"
+version = "1.8"
+
+[dependencies.thread_local]
+version = "1.1"
+
+[dependencies.vulkano-macros]
+version = "0.33.0"
+optional = true
+
+[dev-dependencies.cgmath]
+version = "0.18"
+
+[dev-dependencies.nalgebra]
+version = "0.32"
+
+[build-dependencies.ahash]
+version = "0.8"
+
[build-dependencies.heck]
-version = "0.3"
+version = "0.4"
[build-dependencies.indexmap]
-version = "1.7"
+version = "1.8"
+
+[build-dependencies.once_cell]
+version = "1.16"
+
+[build-dependencies.proc-macro2]
+version = "1.0"
+
+[build-dependencies.quote]
+version = "1.0"
[build-dependencies.regex]
-version = "1.5"
+version = "1.0"
+
+[build-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[build-dependencies.serde_json]
+version = "1.0"
[build-dependencies.vk-parse]
-version = "0.6"
+version = "0.8"
+
+[features]
+default = ["macros"]
+document_unchecked = []
+macros = ["vulkano-macros"]
+
+[target."cfg(target_os = \"ios\")".dependencies.core-graphics-types]
+version = "0.1"
+
+[target."cfg(target_os = \"ios\")".dependencies.objc]
+version = "0.2.5"