aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-07-07 05:09:37 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-07-07 05:09:37 +0000
commit4e4b0ce2db6643f0715fcddc21f1ff4575dbb4ff (patch)
treebb7fed649d07e5b24e581d19ccf3c547b2b86c62 /Cargo.toml
parentbfea4bb5b376161a656cf816fe32ce1beeeebcfa (diff)
parent878f532dd57bdcbce44364b7eecb1811140e99b7 (diff)
downloadwhich-6b2a7acbbf091aeeb07800b67ce209358a642965.tar.gz
Change-Id: Ib03f886e2a58a8d8597759c763b1af608410be99
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 21 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 850a29c..ff6894a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,27 +12,39 @@
[package]
edition = "2018"
name = "which"
-version = "4.2.4"
+version = "4.4.0"
authors = ["Harry Fei <tiziyuanfang@gmail.com>"]
description = "A Rust equivalent of Unix command \"which\". Locate installed executable in cross platforms."
documentation = "https://docs.rs/which/"
readme = "README.md"
-keywords = ["which", "which-rs", "unix", "command"]
-categories = ["os", "filesystem"]
+keywords = [
+ "which",
+ "which-rs",
+ "unix",
+ "command",
+]
+categories = [
+ "os",
+ "filesystem",
+]
license = "MIT"
repository = "https://github.com/harryfei/which-rs.git"
+
[package.metadata.docs.rs]
all-features = true
+
[dependencies.either]
-version = "1.6"
+version = "1.6.1"
[dependencies.libc]
-version = "0.2.65"
+version = "0.2.121"
[dependencies.regex]
-version = "1.5.4"
+version = "1.5.5"
optional = true
-[dev-dependencies.tempdir]
-version = "0.3.7"
-[target."cfg(windows)".dependencies.lazy_static]
+
+[dev-dependencies.tempfile]
+version = "3.3.0"
+
+[target."cfg(windows)".dependencies.once_cell]
version = "1"