aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 10 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 36bb744..bd75632 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,19 +3,18 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "x509-parser"
-version = "0.10.0"
+version = "0.12.0"
authors = ["Pierre Chifflier <chifflier@wzdftpd.net>"]
-include = ["CHANGELOG.md", "LICENSE-*", "README.md", ".gitignore", ".travis.yml", "Cargo.toml", "src/*.rs", "tests/*.rs", "assets/*.der", "assets/*.pem", "examples/*.rs"]
+include = ["CHANGELOG.md", "LICENSE-*", "README.md", ".gitignore", ".travis.yml", "Cargo.toml", "src/*.rs", "tests/*.rs", "assets/*.crl", "assets/*.csr", "assets/*.der", "assets/*.pem", "assets/crl-ext/*.der", "examples/*.rs"]
description = "Parser for the X.509 v3 format (RFC 5280 certificates)"
homepage = "https://github.com/rusticata/x509-parser"
readme = "README.md"
@@ -38,17 +37,17 @@ default-features = false
version = "2.2.1"
[dependencies.der-parser]
-version = "5.1"
+version = "6.0.0"
features = ["bigint"]
[dependencies.lazy_static]
version = "1.4"
[dependencies.nom]
-version = "6.0"
+version = "7.0"
[dependencies.oid-registry]
-version = "0.1.1"
+version = "0.2.0"
features = ["crypto", "x509"]
[dependencies.ring]
@@ -56,7 +55,7 @@ version = "0.16"
optional = true
[dependencies.rusticata-macros]
-version = "3.0"
+version = "4.0"
[dependencies.thiserror]
version = "1.0"