aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml47
1 files changed, 34 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e704337..3279206 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,24 +3,44 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
+edition = "2021"
+rust-version = "1.58"
name = "xml-rs"
-version = "0.8.4"
+version = "0.8.15-cvss-cries-wolf"
authors = ["Vladimir Matveev <vmatveev@citrine.cc>"]
+include = [
+ "src/**",
+ "LICENSE",
+ "README.md",
+]
description = "An XML library in pure Rust"
-documentation = "http://docs.rs/xml-rs/"
-readme = "Readme.md"
-keywords = ["xml", "parsing", "parser"]
-categories = ["parsing"]
+homepage = "https://lib.rs/crates/xml-rs"
+documentation = "https://docs.rs/xml-rs/"
+readme = "README.md"
+keywords = [
+ "xml",
+ "parser",
+ "sax",
+ "parsing",
+ "writer",
+]
+categories = ["parser-implementations"]
license = "MIT"
-repository = "https://github.com/netvl/xml-rs"
+repository = "https://github.com/kornelski/xml-rs"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[package.metadata.release]
+tag-message = ""
+tag-name = "{{version}}"
[lib]
name = "xml"
@@ -29,8 +49,9 @@ path = "src/lib.rs"
[[bin]]
name = "xml-analyze"
path = "src/analyze.rs"
+
[dev-dependencies.doc-comment]
version = "0.3"
-[dev-dependencies.lazy_static]
-version = "1.2.0"
+[badges.maintenance]
+status = "actively-developed"