aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2022-04-28 16:03:05 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2022-04-28 16:03:05 +0000
commit9a0abb35690da6e89c5acb977dbbbf969686b65e (patch)
tree5488828d7446ad70a03375c5837022ef5b4e32e4 /Cargo.toml
parent3355c4646e1bac66db8ee525cad577b658edcf83 (diff)
parent3dd8b2b4380149fb657c4fdbdf70837ccdfdf05b (diff)
downloadzip-9a0abb35690da6e89c5acb977dbbbf969686b65e.tar.gz
Snap for 8512216 from 3dd8b2b4380149fb657c4fdbdf70837ccdfdf05b to tm-frc-art-releaset_frc_art_330443060android13-frc-art-release
Change-Id: I69e66be2c0b8fa493aa224fb8dbaea46c1358e99
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml61
1 files changed, 43 insertions, 18 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e964f60..fe1a031 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,17 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "zip"
-version = "0.5.13"
+version = "0.6.2"
authors = ["Mathijs van de Nes <git@mathijs.vd-nes.nl>", "Marli Frost <marli@frost.red>", "Ryan Levick <ryan.levick@gmail.com>"]
description = "Library to support the reading and writing of zip files.\n"
keywords = ["zip", "archive"]
@@ -23,39 +22,65 @@ repository = "https://github.com/zip-rs/zip.git"
[[bench]]
name = "read_entry"
harness = false
+[dependencies.aes]
+version = "0.7.5"
+optional = true
+
[dependencies.byteorder]
-version = "1.3"
+version = "1.4.3"
[dependencies.bzip2]
-version = "0.4"
+version = "0.4.3"
+optional = true
+
+[dependencies.constant_time_eq]
+version = "0.1.5"
optional = true
[dependencies.crc32fast]
-version = "1.0"
+version = "1.3.2"
[dependencies.flate2]
-version = "1.0.0"
+version = "1.0.22"
optional = true
default-features = false
-[dependencies.thiserror]
-version = "1.0"
+[dependencies.hmac]
+version = "0.12.1"
+features = ["reset"]
+optional = true
+
+[dependencies.pbkdf2]
+version = "0.10.1"
+optional = true
+
+[dependencies.sha1]
+version = "0.10.1"
+optional = true
[dependencies.time]
-version = "0.1"
+version = "0.3.7"
+features = ["formatting", "macros"]
+optional = true
+
+[dependencies.zstd]
+version = "0.10.0"
optional = true
[dev-dependencies.bencher]
-version = "0.1"
+version = "0.1.5"
-[dev-dependencies.rand]
-version = "0.7"
+[dev-dependencies.getrandom]
+version = "0.2.5"
[dev-dependencies.walkdir]
-version = "2"
+version = "2.3.2"
[features]
-default = ["bzip2", "deflate", "time"]
+aes-crypto = ["aes", "constant_time_eq", "hmac", "pbkdf2", "sha1"]
+default = ["aes-crypto", "bzip2", "deflate", "time", "zstd"]
deflate = ["flate2/rust_backend"]
deflate-miniz = ["flate2/default"]
deflate-zlib = ["flate2/zlib"]
unreserved = []
+[target."cfg(any(all(target_arch = \"arm\", target_pointer_width = \"32\"), target_arch = \"mips\", target_arch = \"powerpc\"))".dependencies.crossbeam-utils]
+version = "0.8.8"