aboutsummaryrefslogtreecommitdiff
path: root/source/opt/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Neto <dneto@google.com>2021-08-25 18:16:45 -0400
committerDavid Neto <dneto@google.com>2021-08-25 18:16:45 -0400
commit18d866c00b2f28fc562f2a085c3714d839463f82 (patch)
treeb47c4cbbbc4f3aacc341d71a0672f6b25653373d /source/opt/CMakeLists.txt
parentf4bb11d6389740673bc5b76bfc4d0238e367f8a6 (diff)
parent1fbed83c8aab8517d821fcb4164c08567951938f (diff)
downloadspirv-tools-18d866c00b2f28fc562f2a085c3714d839463f82.tar.gz
Merge commit '1fbed83c8aab8517d821fcb4164c08567951938f' into HEADndk-r24-beta1
Including: 1fbed83c Finalize SPIRV-Tools v2021.3 3d4246b4 Update CHANGES a1d5d67a spirv-val: Validate vulkan debug info similarly to opencl debug info (#4466) 937227c7 Add divergence analysis to linter (#4465) d699296b spirv-val: Fix WorkgroupSize VUID 04425 (#4482) 1ad8b713 spirv-lint: add basic CLI argument handling (#4478) a9ce5e07 Fix matrix stride validation (#4468) e172833b Don't double count variables for location validation (#4474) 926ff6d1 GN: Suppress unreachable code warnings. (#4476) 57e1d8eb Add spirv-opt convert-to-sampled-image pass (#4340) b2e36b67 Disallow loading a runtime-sized array (#4473) 2c829c41 Fix early-out for Clamp constant folding (#4461) 869a550d Don't fold unsigned divides of an constant and a negation (#4457) 88100107 fix SIGSEGV when reading from a non-existant file (#4453) 00b106e7 Limit location validation (#4467) 54524ffa Update SPIRV-Headers (#4463) de69f32e spirv-opt: Add handling of vulkan debug info to DebugInfoManager (#4423) c4c6f2ba spirv-opt: Add dataflow analysis framework (#4402) f9d03bb4 Remove PCH from source/lint/CMakeLists.txt (#4459) 706dc27a Add new target for spirv-lint (#4446) 3510a14c Add a section releases to the README (#4444) 175ecd49 Fix array layout validation slowdown (#4449) 07f13023 spirv-fuzz: Support AtomicStore (#4440) 366d1be5 fuzzers: Disable suggest-destructor-override warning (#4439) 3ab6fb9c Add CMake rules for libFuzzer targets (#4445) 0065c567 spirv-fuzz: support AtomicLoad (#4330) affe280c Add GraphicsFuzz shaders to fuzzer corpus (#4429) c5bda7ae Fuzzer: Default the new constructor parameter (#4438) 5737dbb0 Fix validator crash (#4418) 17bf4437 spirv-fuzz: Add minimal SPIR-V example to test shaders (#4415) c6422cff spirv-opt: Rename ControlDependenceAnalysis::DoesBlockExist to HasBlock (#4412) 983ee231 spirv-opt: Add specific handling of vulkan debug info differences (#4398) 9c448141 spirv-fuzz: Allow inapplicable transformations to be ignored (#4407) c9e094cc spirv-fuzz: Quit fuzzer pass when no types are available (#4409) 4bcd13ff spirv-opt: Add more tests to control dependence (#4410) 7dadcf9c Add control dependence analysis to opt (#4380) 11cd875e spirv-fuzz: Use reference in CanMakeSynonymOf (#4401) 4376a10c Fix public deps on generated headers (#4386) b2db20a7 BUILD.gn: introduce finer grained internal targets for Tint (#4399) 63238d4f Initialize context in `opt::Instruction`'s move constructor (#4397) 183fb9fe spirv-fuzz: Fix problem with instruction context (#4394) 94bcae13 spirv-fuzz: Avoid out-of-bounds access (#4395) cc3fe2b6 spirv-fuzz: Fix vector wrapping fuzzer pass (#4392) 2419f3be spirv-fuzz: Tighten checks on null and undef pointers (#4367) 2a7a561c Fix local size hint id tests (#4400) d9f89257 spirv-opt: Where possible make code agnostic of opencl/vulkan debuginfo (#4385) 033768c2 spirv-fuzz: TransformationWrapVectorSynonym that rewrites scalar operations using vectors (#4376) f084bcfe spirv-fuzz: Support atomic operations opcode (#4348) 3a68a727 CMake: add ENABLE_RTTI option (#4382) 8966cc2b Add common enum for debug info instructions from either opencl or vulkan (#4377) 5427d5cf Don't mention VS2013 in PR review instructions (#4384) 7320b9ac Explain how to run tests with CMake and Bazel (#4383) e0937d7f spirv-fuzz: Don't replace memory semantics / scope operands (#4349) 2685c9a6 Add missing fuzzer header dependency. (#4381) 640b17b5 Fix -Wunreachable-code-aggressive. (#4358) 4baf3aff spirv-opt: support SPV_EXT_shader_image_int64 (#4379) feb05446 Fix BUILD.gn (#4378) 2299b710 spirv-fuzz: support building using gn (#4365) d432bebb Fix vendor table build in BUILD.gn for nonsemantic.vulkan.debuginfo.100 (#4375) 3b6abf41 Add non-semantic vulkan extended instruction set (#4362) c26baf4c Update SPIRV-Headers deps (#4369) 9ce7a2fb spirv-reduce: Eliminate skeletal structured control flow construct (#4360) 4d2832e3 spirv-fuzz: Check updated analyses in transformation tests (#4266) 77633605 spirv-fuzz: Added tests for signedness analysis (#4361) a95bc460 Add remove_unused_interface_variable_pass.* to BUILD.gn (#4363) c67f1320 add tests for SPV_KHR_bit_instructions (#4350) 06f114d4 spirv-fuzz: Avoid out of bounds access (#4355) 74e8105e Enabled tvOS platform (#4329) f9893c45 spirv-opt: A pass to removed unused input on OpEntryPoint instructions. (#4275) 8442a181 Bump glob-parent from 5.0.0 to 5.1.2. (#4353) eeff9af1 fix strncpy bound error (#4331) b8587c98 spirv-reduce: Allow merging unreachable blocks (#4303) 4fcdc589 Add IsReachable function to IRContext (#4323) 237173a0 spirv-reduce: Cleanup a few things (#4352) 8cc8b656 spirv-fuzz: Add illustrative tests for new issues (#4347) 3a02d112 Add validation for SPV_EXT_shader_atomic_float16_add (#4325) e065c482 Initial support for SPV_KHR_integer_dot_product (#4327) e992c96c fix symbol exports check, for Android build cases (#4342) 0c21e509 Start SPIRV-Tools v2021.3 e198c6a7 Finalize SPIRV-Tools v2021.2 f8eafd4d spirv-val: Label VUID 04780 (#4334) e84bcb25 spirv-val: Add GLCompute to VUID 04644 message (#4333) Testing: checkbuild.py on Linux Change-Id: I513d871f80a9a305a2cb93f7ac5f0ce11184a940
Diffstat (limited to 'source/opt/CMakeLists.txt')
-rw-r--r--source/opt/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/source/opt/CMakeLists.txt b/source/opt/CMakeLists.txt
index 88d56589..63af5c1d 100644
--- a/source/opt/CMakeLists.txt
+++ b/source/opt/CMakeLists.txt
@@ -27,8 +27,11 @@ set(SPIRV_TOOLS_OPT_SOURCES
composite.h
const_folding_rules.h
constants.h
+ control_dependence.h
+ convert_to_sampled_image_pass.h
convert_to_half_pass.h
copy_prop_arrays.h
+ dataflow.h
dead_branch_elim_pass.h
dead_insert_elim_pass.h
dead_variable_elimination.h
@@ -96,6 +99,7 @@ set(SPIRV_TOOLS_OPT_SOURCES
register_pressure.h
relax_float_ops_pass.h
remove_duplicates_pass.h
+ remove_unused_interface_variables_pass.h
replace_invalid_opc.h
scalar_analysis.h
scalar_analysis_nodes.h
@@ -132,8 +136,11 @@ set(SPIRV_TOOLS_OPT_SOURCES
composite.cpp
const_folding_rules.cpp
constants.cpp
+ control_dependence.cpp
+ convert_to_sampled_image_pass.cpp
convert_to_half_pass.cpp
copy_prop_arrays.cpp
+ dataflow.cpp
dead_branch_elim_pass.cpp
dead_insert_elim_pass.cpp
dead_variable_elimination.cpp
@@ -197,6 +204,7 @@ set(SPIRV_TOOLS_OPT_SOURCES
register_pressure.cpp
relax_float_ops_pass.cpp
remove_duplicates_pass.cpp
+ remove_unused_interface_variables_pass.cpp
replace_invalid_opc.cpp
scalar_analysis.cpp
scalar_analysis_simplification.cpp