aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-07-07 05:08:08 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-07-07 05:08:08 +0000
commit7882154156e82dcbd2b3d69dadb9e090b8d95536 (patch)
treedec5574d9317bfd36e5dc80f96a42bef57b6fbf1 /configure.ac
parent3186891a35e6ed3ffb967fc5f541c7b12a5ac00a (diff)
parent77d90124a84917e1dfecabf821d61795ad64b1d9 (diff)
downloadspeex-7882154156e82dcbd2b3d69dadb9e090b8d95536.tar.gz
Change-Id: I0db8fda8556834adeaf39053e653c5f344fdb4ad
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac64
1 files changed, 22 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 2cd2d1e..19361cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script. -*-m4-*-
-AC_INIT([speexdsp],[1.2rc3],[speex-dev@xiph.org])
+AC_INIT([speexdsp],[1.2.1],[speex-dev@xiph.org])
AC_CONFIG_SRCDIR([libspeexdsp/preprocess.c])
AC_CONFIG_MACRO_DIR([m4])
@@ -10,7 +10,7 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
SPEEXDSP_LT_CURRENT=6
-SPEEXDSP_LT_REVISION=0
+SPEEXDSP_LT_REVISION=2
SPEEXDSP_LT_AGE=5
@@ -22,8 +22,8 @@ AM_INIT_AUTOMAKE([foreign no-define])
AM_MAINTAINER_MODE([enable])
AC_CANONICAL_HOST
-AC_LIBTOOL_WIN32_DLL
-AM_PROG_LIBTOOL
+_LT_SET_OPTION([LT_INIT],[win32-dll])
+LT_INIT
AC_C_BIGENDIAN
AC_C_CONST
@@ -32,38 +32,15 @@ AC_C_RESTRICT
AC_MSG_CHECKING(for C99 variable-size arrays)
-AC_TRY_COMPILE( , [
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
int foo;
foo = 10;
int array[foo];
-],
-[has_var_arrays=yes;AC_DEFINE([VAR_ARRAYS], [], [Use C99 variable-size arrays])
-],
-has_var_arrays=no
-)
+]])],[has_var_arrays=yes;AC_DEFINE([VAR_ARRAYS], [], [Use C99 variable-size arrays])
+],[has_var_arrays=no
+])
AC_MSG_RESULT($has_var_arrays)
-AC_CHECK_HEADERS([alloca.h getopt.h])
-AC_MSG_CHECKING(for alloca)
-AC_TRY_COMPILE( [
-#ifdef HAVE_ALLOCA_H
-# include <alloca.h>
-#endif
-#include <stdlib.h>
-], [
-int foo=10;
-int *array = alloca(foo);
-],
-[
-has_alloca=yes;
-if test x$has_var_arrays = "xno" ; then
-AC_DEFINE([USE_ALLOCA], [], [Make use of alloca])
-fi
-],
-has_alloca=no
-)
-AC_MSG_RESULT($has_alloca)
-
AC_MSG_CHECKING(for SSE in current arch/CFLAGS)
AC_LINK_IFELSE([
AC_LANG_PROGRAM([[
@@ -143,11 +120,6 @@ AC_SUBST(src)
LT_LIB_M
-AC_ARG_ENABLE(valgrind, [ --enable-valgrind Enable valgrind extra checks],
-[if test "$enableval" = yes; then
- AC_DEFINE([ENABLE_VALGRIND], , [Enable valgrind extra checks])
-fi])
-
AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
if test "x$enableval" != xno; then
has_sse=yes
@@ -162,7 +134,9 @@ fi
AC_ARG_ENABLE(neon, [ --enable-neon Enable NEON support], [
if test "x$enableval" != xno; then
has_neon=yes
-CFLAGS="$CFLAGS -O3 -march=armv7-a -mfpu=neon"
+AS_CASE(["$host"],
+ [arm*], [CFLAGS="$CFLAGS -O3 -march=armv7-a -mfpu=neon"]
+)
else
has_neon=no
fi
@@ -182,15 +156,15 @@ fi],
AC_DEFINE([FLOATING_POINT], , [Compile as floating-point]))
if test "$has_sse" = yes; then
- AC_DEFINE([_USE_SSE], , [Enable SSE support])
+ AC_DEFINE([USE_SSE], , [Enable SSE support])
fi
if test "$has_neon" = yes; then
- AC_DEFINE([_USE_NEON], , [Enable NEON support])
+ AC_DEFINE([USE_NEON], , [Enable NEON support])
fi
if test "$has_sse2" = yes; then
- AC_DEFINE([_USE_SSE2], , [Enable SSE2 support])
+ AC_DEFINE([USE_SSE2], , [Enable SSE2 support])
fi
AC_ARG_ENABLE(float-api, [ --disable-float-api Disable the floating-point API],
@@ -334,11 +308,17 @@ AC_SUBST([USIZE16])
AC_SUBST([SIZE32])
AC_SUBST([USIZE32])
+AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
+ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
+ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
+
+AC_SUBST([INCLUDE_STDINT])
+
AC_CONFIG_FILES([
Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
include/Makefile include/speex/Makefile speexdsp.pc
win32/Makefile win32/libspeexdsp/Makefile
- symbian/Makefile
+ symbian/Makefile
win32/VS2003/Makefile
win32/VS2003/libspeexdsp/Makefile
@@ -351,7 +331,7 @@ AC_CONFIG_FILES([
win32/VS2008/Makefile
win32/VS2008/libspeexdsp/Makefile
win32/VS2008/tests/Makefile
- include/speex/speexdsp_config_types.h ti/Makefile
+ include/speex/speexdsp_config_types.h ti/Makefile
ti/speex_C54_test/Makefile ti/speex_C55_test/Makefile
ti/speex_C64_test/Makefile ])