aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGiuliano Procida <gprocida@google.com>2024-04-25 22:08:58 +0100
committerGiuliano Procida <gprocida@google.com>2024-04-25 22:08:58 +0100
commit03ab09f3cb3ff287985df9aabcd812b7890a09ce (patch)
treeb126f296e5f4f7cc626593736ad8d659fefefa36 /CMakeLists.txt
parent068cfa080c14905c6670383b68150070269d4431 (diff)
parent6e2c034f8024dd0fa1d3180c26ec4f75f41b92ce (diff)
downloadstg-03ab09f3cb3ff287985df9aabcd812b7890a09ce.tar.gz
Merge branch 'upstream-main' into 'main'
* aosp/upstream-main: CMake: express current dependency on Catch2 v2 proto writer: take references to key/value pairs in ID mapping loop rust: add test case for rust tagged enums comparison: use a cleaner enum for Ignore options rust: add `Variant` node rust: add `VariantMember` node rust: add info test for member functions in Rust enums test suite: rename Abigail reader input files to `<test-name>_<language>.xml` Signed-off-by: Giuliano Procida <gprocida@google.com> Change-Id: Ie3d7a6e3c84586328b4e1b5edb297090381ec7b0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9587c6a..38bb294 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,11 +117,11 @@ endforeach()
# Testing
-find_package(Catch2 QUIET)
+find_package(Catch2 2 QUIET)
if(NOT Catch2_FOUND)
- message(NOTICE "Catch2 testing framework not found. Disabling tests.")
+ message(NOTICE "Catch2 v2 testing framework not found. Disabling tests.")
else()
enable_testing()