aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4aa9846c2..3ea56a14c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1102,10 +1102,9 @@ $(srcdir)/CREDITS: $(srcdir)/CREDITS.in $(srcdir)/.mailmap \
( \
cd $(srcdir); \
sed '/^##/,$$d' CREDITS.in; \
- { sed -n '1,/^##>/d; s/ */\t/; s/^./&/p' CREDITS.in; \
- git log --pretty=format:'%aN %aE'; \
- } | LC_ALL=C sort -u \
- | awk -F'\t' '{printf("\t%s <%s>\n",$$1,$$2)}'; \
+ sed -n '1,/^##>/d; s/ */\t/; s/^./&/p' CREDITS.in \
+ | maint/gen-contributors-list.sh - -e HEAD --initial \
+ | sed 's/\t/ /g; s/^/\t/' \
) > $@-t && mv $@-t $@
export TAR_OPTIONS = --owner=0 --group=0 --numeric-owner --mode=go-w,go+rX