aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWei Huang <wei@redhat.com>2017-11-20 23:40:54 -0500
committerWei Huang <wei@redhat.com>2017-11-20 23:06:56 -0600
commit8345145a97f226a2f1e403d6638527d69e446c08 (patch)
tree81586ad4d01da78510fc00b0f6975a3df9dc21a0 /configure.ac
parent1bc69459b5ba325a9da54c820696b33607b1af2f (diff)
downloadstressapptest-8345145a97f226a2f1e403d6638527d69e446c08.tar.gz
Add STRESSAPPTEST_CPU_AARCH64 defintion for aarch64 CPU
This patch adds a new macro, STRESSAPPTEST_CPU_AARCH64, for aarch64 CPUs. The file stressapptest_config.h.in is also refreshed using autoheader. Signed-off-by: Wei Huang <wei@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2b20a48..06b5868 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,11 @@ AS_CASE(["$host_cpu"],
AC_DEFINE([STRESSAPPTEST_CPU_ARMV7A],[],
[Defined if the target CPU is armv7a])
],
- [AC_MSG_WARN([Unsupported CPU: $host_cpu! Try x86_64, i686, powerpc, or armv7a])]
+ [*aarch64*], [
+ AC_DEFINE([STRESSAPPTEST_CPU_AARCH64],[],
+ [Defined if the target CPU is aarch64])
+ ],
+[AC_MSG_WARN([Unsupported CPU: $host_cpu! Try x86_64, i686, powerpc, armv7a, or aarch64])]
)
## The following allows like systems to share settings. This is not meant to