aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornick.j.sanders <nick.j.sanders@93e54ea4-8218-11de-8aaf-8d8425684b44>2010-03-12 03:35:04 +0000
committernick.j.sanders <nick.j.sanders@93e54ea4-8218-11de-8aaf-8d8425684b44>2010-03-12 03:35:04 +0000
commiteea0aac32a3f522ea51d389f44dcd8abcfc5a6e0 (patch)
tree59416ffedb7a81de22f3421154e4448a1280c754 /configure.ac
parentf56c2554279a4a9e3aa67a30411c4b764cc7e69d (diff)
downloadstressapptest-eea0aac32a3f522ea51d389f44dcd8abcfc5a6e0.tar.gz
Update stressapptest to 1.0.2
* Fix -d option on 32 bit build. * Fix -d bandwidth calculation * DiskThread general cleanup * Add libaio dependency for cross platform builds * Allow > 32 cores * Add support for --tag_mode and -W on the same run * General error handling cleanup * Improve checksum generation failure handling - printout core, node, dimm. * -H option specifies minimum required hugepage allocation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 33 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a7bdb86..5011c89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.61)
-AC_INIT(stressapptest, 1.0.1_autoconf, opensource@google.com)
+AC_INIT(stressapptest, 1.0.2_autoconf, opensource@google.com)
AC_CANONICAL_HOST
AC_CANONICAL_BUILD
@@ -87,6 +87,7 @@ CXXFLAGS="$CXXFLAGS -O3 -funroll-all-loops -funroll-loops -DNDEBUG"
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h unistd.h])
+AC_CHECK_HEADERS([pthread.h libaio.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -132,6 +133,37 @@ else
LDFLAGS="$LDFLAGS $pthread_arg"
fi
+# Checking for libaio
+libaio_arg="not_available"
+AC_MSG_CHECKING([which argument is required to compile libaio])
+
+libaio_header="#include<libaio.h>"
+libaio_body="io_submit(0,0,0)"
+# Check if compile with no extra argument
+AC_LINK_IFELSE([AC_LANG_PROGRAM($libaio_header, $libaio_body)],
+libaio_arg="")
+
+if test x"$libaio_arg" = x"not_available"; then
+ bkp_LDFLAGS="$LDFLAGS"
+ for altheader in -laio; do
+ LDFLAGS="$bkp_LDFLAGS $altheader"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM($libaio_header, $libaio_body)],
+ libaio_arg="$altheader")
+ LDFLAGS="$bkp_LDFLAGS"
+ done
+fi
+
+if test x"$libaio_arg" = x"not_available"; then
+ AC_MSG_FAILURE([Cannot find libaio library, please install libaio-dev])
+else
+ if test x"$libaio_arg" = x; then
+ AC_MSG_RESULT([none])
+ else
+ AC_MSG_RESULT([$libaio_arg])
+ fi
+ LDFLAGS="$LDFLAGS $libaio_arg"
+fi
+
# Checks for library functions.
AC_FUNC_CLOSEDIR_VOID
AC_PROG_GCC_TRADITIONAL