aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2020-02-04 19:53:11 -0800
committerGuy Harris <guy@alum.mit.edu>2020-02-04 19:53:11 -0800
commit52561ff05323cc5aae2bf836ecccf62c878b7690 (patch)
tree4644f3f853b645b8ba5f048e99e442018daf4913 /CMakeLists.txt
parentaa2650ec0e9f4146a4f3c4dc9c3c58d231bbfef9 (diff)
downloadtcpdump-52561ff05323cc5aae2bf836ecccf62c878b7690.tar.gz
Push the floating-point test into a separate file.
Hopefully, that will make sure we don't optimize away anything that will, for example, cause us not to do things differently on 32-bit x86 using the x87 instructions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7fa6e900..b946c17d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1110,7 +1110,7 @@ if(NOT C_ADDITIONAL_FLAGS STREQUAL "")
set_target_properties(netdissect PROPERTIES COMPILE_FLAGS ${C_ADDITIONAL_FLAGS})
endif()
-set(TCPDUMP_SOURCE_LIST_C tcpdump.c)
+set(TCPDUMP_SOURCE_LIST_C fptype.c tcpdump.c)
if(NOT HAVE_BPF_DUMP)
set(TCPDUMP_SOURCE_LIST_C ${TCPDUMP_SOURCE_LIST_C} bpf_dump.c)