aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDenis Ovsienko <denis@ovsienko.info>2023-02-17 08:56:15 +0000
committerFrancois-Xavier Le Bail <devel.fx.lebail@orange.fr>2023-10-12 10:45:04 +0200
commit9c9c41173afaf41666f500977cfc9c13678cb2a3 (patch)
treef456fa698a93dabf90f1382716c11f176f11beca /CMakeLists.txt
parentd18a0ddb84361fe7ef7c8cdb4c0d365a675a6ec6 (diff)
downloadtcpdump-9c9c41173afaf41666f500977cfc9c13678cb2a3.tar.gz
Do not require vsnprintf().
The check for vsnprintf() has been in the configure script since commit 8cb054c in 2000, and the only actual use of the function was in the "#ifndef HAVE_SNPRINTF" block in missing/snprintf.c until commit 1ed63b5 in 2019. Since then tcpdump does not require vsnprintf() in any way. (cherry picked from commit a69de5a4d94baabdceb22a174b116b6e45ed72b9)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 377f161a..09810815 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -399,15 +399,11 @@ endif(STDLIBS_HAVE_GETSERVENT)
cmake_pop_check_state()
#
-# Make sure we have vsnprintf() and snprintf(); we require them.
-# We use check_symbol_exists(), as they aren't necessarily external
-# functions - in Visual Studio, for example, they're inline functions
-# calling a common external function.
-#
-check_symbol_exists(vsnprintf "stdio.h" HAVE_VSNPRINTF)
-if(NOT HAVE_VSNPRINTF)
- message(FATAL_ERROR "vsnprintf() is required but wasn't found")
-endif(NOT HAVE_VSNPRINTF)
+# Make sure we have snprintf(); we require it.
+# We use check_symbol_exists(), as it isn't necessarily an external
+# function - in Visual Studio, for example, it is an inline function
+# calling an external function.
+#
check_symbol_exists(snprintf "stdio.h" HAVE_SNPRINTF)
if(NOT HAVE_SNPRINTF)
message(FATAL_ERROR "snprintf() is required but wasn't found")