aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois-Xavier Le Bail <devel.fx.lebail@orange.fr>2024-03-27 23:37:08 +0100
committerFrancois-Xavier Le Bail <devel.fx.lebail@orange.fr>2024-05-15 10:34:56 +0200
commitf67e46a634dd3bdcefa9fc09dbef6baae1b1d1ed (patch)
tree7e7e14dd49291174cc036de62965cc8f25dc47c3 /CMakeLists.txt
parentc5c912ad34a88dcf5878be64b36daa535c5265f9 (diff)
downloadtcpdump-f67e46a634dd3bdcefa9fc09dbef6baae1b1d1ed.tar.gz
Include <config.h> unconditionally
Builds using Autotools or CMake generate config.h, thus remove the '#ifdef HAVE_CONFIG_H'/'#endif'. Remove also the 'add_definitions(-DHAVE_CONFIG_H)' in CMakeLists.txt. (backported from commit 94a3708f00f658994293a440fbbb7e71e2047a0f)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 767379ab..08701bed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -279,8 +279,6 @@ file(STRINGS ${tcpdump_SOURCE_DIR}/VERSION
# Project settings
######################################
-add_definitions(-DHAVE_CONFIG_H)
-
include_directories(
${CMAKE_CURRENT_BINARY_DIR}
${tcpdump_SOURCE_DIR}