aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorambrosin <ambrosin@google.com>2023-04-25 06:56:53 -0700
committerCopybara-Service <copybara-worker@google.com>2023-04-25 06:58:06 -0700
commit411e3cfce3219224f5916690f731112ab3751850 (patch)
tree005f4ecba18a90551e969a221c80de1c82fe1c8d /CMakeLists.txt
parentbc708f319491eadd300e8e4d17e307075cdfc8bc (diff)
downloadtink-411e3cfce3219224f5916690f731112ab3751850.tar.gz
Set minimum supported CMake version to 3.13
The current minimum supported version in https://github.com/google/oss-policies-info/blob/main/foundational-cxx-support-matrix.md is 3.10, but this is going to change to 3.13 from May 1st because Ubuntu 18.04 will be no longer supoported. 3.13 is the older version that comes packaged with the supported distros (Debian 10 in this case). See https://opensource.google/documentation/policies/cplusplus-support#support_criteria_3 PiperOrigin-RevId: 526954498
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a05ee7706..3f26205d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.10)
+cmake_minimum_required(VERSION 3.13)
project(Tink VERSION 1.7.0 LANGUAGES CXX)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")