aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorambrosin <ambrosin@google.com>2023-03-08 06:17:50 -0800
committerCopybara-Service <copybara-worker@google.com>2023-03-08 06:19:10 -0800
commita1b31d0a4aad80263ea1fcea13a296893986be72 (patch)
treef45c2b1b56c85056bbe37eb2c2fb01687ada322f /CMakeLists.txt
parentef7dc3bbbef14814639ebe152e2f65a1d545e6c5 (diff)
downloadtink-a1b31d0a4aad80263ea1fcea13a296893986be72.tar.gz
Remove the custom crypto::tink::util::Staus{|Or} implementation
Also remove Kokoro test scripts that used `--//config:tink_use_absl_statusor=True`. PiperOrigin-RevId: 515018353
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b0edc80c..a05ee7706 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,6 @@ option(TINK_BUILD_TESTS "Build Tink tests" OFF)
option(TINK_USE_SYSTEM_OPENSSL "Build Tink linking to OpenSSL installed in the system" OFF)
option(TINK_USE_INSTALLED_ABSEIL "Build Tink linking to Abseil installed in the system" OFF)
option(TINK_USE_INSTALLED_GOOGLETEST "Build Tink linking to GTest installed in the system" OFF)
-option(TINK_USE_ABSL_STATUS "Compile Tink with absl::Status" OFF)
-option(TINK_USE_ABSL_STATUSOR "Compile Tink with absl::StatusOr" OFF)
option(USE_ONLY_FIPS "Enables the FIPS only mode in Tink" OFF)
set(CPACK_GENERATOR TGZ)