aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlizatretyakova <lizatretyakova@google.com>2022-05-05 07:38:47 -0700
committerCopybara-Service <copybara-worker@google.com>2022-05-05 07:40:09 -0700
commite2ba17ab7b6a392e46e9daebd8fbb02265074fab (patch)
tree2b52bcd7a3644e5517a641979e46a2a2bfde22cc /CMakeLists.txt
parent806e1b86a543c8b1dd3432408d19fb13853497c3 (diff)
downloadtink-e2ba17ab7b6a392e46e9daebd8fbb02265074fab.tar.gz
Move options definitions into the single place in the main CMakeLists file. Replace add_definitions() rule with target_compile_definitions() to follow cmake's best practices.
PiperOrigin-RevId: 446713577
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9eadde7ab..dcb7e45e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@ option(TINK_USE_INSTALLED_ABSEIL "Build Tink linking to Abseil installed in the
option(TINK_USE_INSTALLED_GOOGLETEST "Build Tink linking to GTest installed in the system" OFF)
option(TINK_USE_ABSL_STATUS "Compile Tink with absl::Status" OFF)
option(TINK_USE_ABSL_STATUSOR "Compile Tink with absl::StatusOr" OFF)
+option(USE_ONLY_FIPS "Enables the FIPS only mode in Tink" OFF)
set(CPACK_GENERATOR TGZ)
set(CPACK_PACKAGE_VERSION ${PROJECT_VERSION})