aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorambrosin <ambrosin@google.com>2022-02-03 00:54:16 -0800
committerCopybara-Service <copybara-worker@google.com>2022-02-03 00:54:59 -0800
commitf73835dbc64e4724a4ae07a0335aea58bb9f72c3 (patch)
treedc41c61d521c53b5b182237bf9c111daeeeec1f0 /CMakeLists.txt
parent573ca7917f00d28f3709fd89a9f4d6d1fb3b5719 (diff)
downloadtink-f73835dbc64e4724a4ae07a0335aea58bb9f72c3.tar.gz
Add option to link against installed GTest.
Add a macro to create interface targets. PiperOrigin-RevId: 426077117
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b3dcd4c9..1a0bf68fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
option(TINK_BUILD_TESTS "Build Tink tests" OFF)
option(TINK_USE_SYSTEM_OPENSSL "Build Tink linking to OpenSSL installed in the system" OFF)
option(TINK_USE_INSTALLED_ABSEIL "Build Tink linking to Abseil installed in the system" OFF)
+option(TINK_USE_INSTALLED_GOOGLETEST "Build Tink linking to GTest installed in the system" OFF)
set(CPACK_GENERATOR TGZ)
set(CPACK_PACKAGE_VERSION ${TINK_VERSION_LABEL})