aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTink Team <tink-dev@google.com>2019-03-19 08:39:12 -0700
committerTink Team <noreply@google.com>2019-03-20 11:40:55 -0400
commit4dd3b07a0ae92a790ae2183c58b83902f2f41964 (patch)
tree8ef074069888622284884d964d3923dc39adf196 /CMakeLists.txt
parentc3ef5a791cccff0334da45aa92b7aea3df3a35b9 (diff)
downloadtink-4dd3b07a0ae92a790ae2183c58b83902f2f41964.tar.gz
Turn TINK_BUILD_TESTS into an option, disable it by default.
PiperOrigin-RevId: 239196540 GitOrigin-RevId: 3c494c5339afe6ac88452fd922fd849215cf4e42
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bccfa821b..b69692224 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,8 @@ include(tink_version.cmake)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+option(TINK_BUILD_TESTS "Build Tink tests" OFF)
+
include(TinkWorkspace)
include(TinkBuildRules)
include(TinkUtil)