aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBradley Clemetson <brad.clemetson@codeprogrammers.net>2014-01-25 18:25:22 -0800
committerBradley Clemetson <brad.clemetson@codeprogrammers.net>2014-01-25 18:25:22 -0800
commit89d5b69beebd59c97db54aa1ea19019a8d7d1a05 (patch)
treecbd567b9b52c8ee882addf2cd9cde0684aae037b /CMakeLists.txt
parent89a5192702673133c5c740d9cec47da107578500 (diff)
downloadtinyobjloader-89d5b69beebd59c97db54aa1ea19019a8d7d1a05.tar.gz
Added a Cmake build system configuration
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..72bb155
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,33 @@
+#Tiny Object Loader Cmake configuration file.
+#This configures the Cmake system with multiple properties, depending
+#on the platform and configuration it is set to build in.
+project(tinyobjloader)
+cmake_minimum_required(VERSION 2.8.6)
+
+#Folder Shortcuts
+set(TINYOBJLOADEREXAMPLES_DIR ${CMAKE_CURRENT_SOURCE_DIR}/examples)
+
+set(tinyobjloader-Source
+ ${CMAKE_CURRENT_SOURCE_DIR}/tiny_obj_loader.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/tiny_obj_loader.cc
+ )
+
+set(tinyobjloader-Test-Source
+ ${CMAKE_CURRENT_SOURCE_DIR}/test.cc
+ )
+
+set(tinyobjloader-examples-objsticher
+ ${TINYOBJLOADEREXAMPLES_DIR}/obj_sticher/obj_writer.h
+ ${TINYOBJLOADEREXAMPLES_DIR}/obj_sticher/obj_writer.cc
+ ${TINYOBJLOADEREXAMPLES_DIR}/obj_sticher/obj_sticher.cc
+ )
+
+add_library(tinyobjloader
+ ${tinyobjloader-Source}
+ )
+
+add_executable(test ${tinyobjloader-Test-Source})
+target_link_libraries(test tinyobjloader)
+
+add_executable(obj_sticher ${tinyobjloader-examples-objsticher})
+target_link_libraries(obj_sticher tinyobjloader) \ No newline at end of file