aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAbel Luck <abel@guardianproject.info>2013-04-11 18:12:52 +0200
committerAbel Luck <abel@guardianproject.info>2013-04-11 18:30:00 +0200
commitece86fdd284916810b3d4f7b37e6753ce3a2aa2b (patch)
tree214d48b8fbdcc36d3c4a97775264cda1244adbc8 /configure.ac
parentf8fd2f85607f3286208e97e607b78358b6016873 (diff)
downloadtlsdate-ece86fdd284916810b3d4f7b37e6753ce3a2aa2b.tar.gz
build on android
Android's libc lacks several functions required by tlsdate, so I've dropped implementations of them in src/android and conditionally included them where necessary.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0df7d5f..99be698 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,9 +193,20 @@ case "$host" in
[""|yes|no], [UNPRIV_GROUP="nogroup"],
[*], [UNPRIV_GROUP=$with_unpriv_group])
AC_DEFINE_UNQUOTED([UNPRIV_GROUP], ["${UNPRIV_GROUP}"], [Unprivileged group])
+ case "$host" in
+ *-linux-androideabi)
+ dnl This is for Android NDK as it is a special case of linux
+ AC_DEFINE(HAVE_ANDROID,1, [Defined if we are to build for an Android system])
+ AC_SUBST(HAVE_ANDROID, [1])
+ HAVE_ANDROID="yes"
+ ;;
+ esac
;;
esac
+dnl Android conditional
+AM_CONDITIONAL(HAVE_ANDROID, test "x${HAVE_ANDROID}" = "xyes")
+
AC_MSG_CHECKING([user/group to drop privs to])
AC_ARG_WITH([unpriv-user],