aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaurav Shah <gauravsh@google.com>2014-04-10 18:42:44 -0700
committerchrome-internal-fetch <chrome-internal-fetch@google.com>2014-04-15 03:54:57 +0000
commit29e6fc32118997db093520429f645a7f1dada03f (patch)
tree5d98c1f977e4c7acd0841f686aa9b3efb6f67a1f /configure.ac
parentfc78f7e8d4c6acc8ab8bd82fa7d23648838c4009 (diff)
downloadtlsdate-29e6fc32118997db093520429f645a7f1dada03f.tar.gz
tlsdate: Allow explicitly disabling seccomp support
Allow building without seccomp filter support if requested. This is currently not the case when cross-compiling, where seccomp support is default assumed. BUG=chromium:358444 TEST='USE=-seccomp emerge-mipsel-o32-generic tlsdate' now builds. CQ-DEPEND=CL:194323 Change-Id: I105d9a7238f49c87ee4c060ca5ef160239628410 Reviewed-on: https://chromium-review.googlesource.com/194289 Reviewed-by: Mike Frysinger <vapier@chromium.org> Reviewed-by: Will Drewry <wad@chromium.org> Tested-by: Gaurav Shah <gauravsh@chromium.org> Commit-Queue: Gaurav Shah <gauravsh@chromium.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1b1cb57..b9428f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,6 +140,10 @@ AS_IF([test "x$enable_seccomp_filter" = xyes], [
have_seccomp_filter=true
AC_MSG_RESULT([forced])
], [
+ AS_IF([test "x$enable_seccomp_filter" = xno], [
+ have_seccomp_filter=no
+ AC_MSG_RESULT([disabled])
+ ], [
dnl Detect seccomp filter support.
AC_RUN_IFELSE([AC_LANG_PROGRAM([[
#include <errno.h>
@@ -163,7 +167,7 @@ AS_IF([test "x$enable_seccomp_filter" = xyes], [
have_seccomp_filter=true
]
)
-])
+])])
AS_IF([${have_seccomp_filter}], [
AC_DEFINE([HAVE_SECCOMP_FILTER], [1], [Enable seccomp filter])