aboutsummaryrefslogtreecommitdiff
path: root/llvm_tools/patch_sync/Cargo.toml
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2022-02-17 03:31:04 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2022-02-17 03:31:04 +0000
commit03efa96a457031a7966cd54a2a848af49e363daa (patch)
treecf4cdad04e1c146844e2a790910cf9cd1b97082a /llvm_tools/patch_sync/Cargo.toml
parent407345e89a2d292f58092deb712ec71a49ab8b97 (diff)
parent9d023268dcf468f9d4bbd874545c9c230e7549b3 (diff)
downloadtoolchain-utils-03efa96a457031a7966cd54a2a848af49e363daa.tar.gz
Snap for 8191477 from 9d023268dcf468f9d4bbd874545c9c230e7549b3 to tm-frc-permission-release
Change-Id: Ic4fce9ced5c75b310ade25d77de85ec3b9848dde
Diffstat (limited to 'llvm_tools/patch_sync/Cargo.toml')
-rw-r--r--llvm_tools/patch_sync/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/llvm_tools/patch_sync/Cargo.toml b/llvm_tools/patch_sync/Cargo.toml
new file mode 100644
index 00000000..43082627
--- /dev/null
+++ b/llvm_tools/patch_sync/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "patch_sync"
+version = "0.1.0"
+authors = ["Jordan R Abrahams-Whitehead <ajordanr@google.com>"]
+edition = "2018"
+
+[profile.release]
+panic = "abort"
+
+[dependencies]
+anyhow = "1.0"
+regex = "1.5"
+serde = {version = "1.0", features = ["derive"]}
+serde_json = "1.0"
+sha2 = "0.9"
+structopt = "0.3"
+time = "0.3"
+
+[dev-dependencies]
+rand = "0.8"