aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Fuchs <andreas.fuchs@sit.fraunhofer.de>2019-05-15 17:33:54 +0200
committerAndreas Fuchs <andreas.fuchs@sit.fraunhofer.de>2019-05-17 10:34:09 +0200
commit034d1cade4bc476756ca5302acfffcea3def6bff (patch)
tree5992837718c5dcd9b7e0a1188ce8abf634dc2fda /Makefile.am
parent28143b43a35e92a01bd475a0e542a40702af57f7 (diff)
downloadtpm2-tss-034d1cade4bc476756ca5302acfffcea3def6bff.tar.gz
Build: switch to git.mk
Signed-off-by: Andreas Fuchs <andreas.fuchs@sit.fraunhofer.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1037b6ea..02189fe2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,8 @@
# Copyright (c) 2018 Fraunhofer SIT sponsored by Infineon Technologies AG
# All rights reserved.
+-include $(top_srcdir)/git.mk
+
### Initialize global variables used throughout the file ###
INCLUDE_DIRS = -I$(srcdir)/src -I$(srcdir)/include/tss2
ACLOCAL_AMFLAGS = -I m4 --install
@@ -17,6 +19,28 @@ DISTCLEANFILES =
CLEANFILES =
MOSTLYCLEANFILES =
noinst_PROGRAMS =
+MAINTAINERCLEANFILES = \
+ $(GITIGNORE_MAINTAINERCLEANFILES_TOPLEVEL) \
+ $(GITIGNORE_MAINTAINERCLEANFILES_MAKEFILE_IN) \
+ $(GITIGNORE_MAINTAINERCLEANFILES_M4_LIBTOOL) \
+ src_vars.mk \
+ Makefile-fuzz-generated.am \
+ aminclude_static.am \
+ m4/ax_ac_append_to_file.m4 \
+ m4/ax_ac_print_to_file.m4 \
+ m4/ax_add_am_macro_static.m4 \
+ m4/ax_am_macros_static.m4 \
+ m4/ax_check_compile_flag.m4 \
+ m4/ax_check_gnu_make.m4 \
+ m4/ax_check_link_flag.m4 \
+ m4/ax_check_preproc_flag.m4 \
+ m4/ax_code_coverage.m4 \
+ m4/ax_file_escapes.m4 \
+ m4/ax_normalize_path.m4 \
+ m4/ax_prog_doxygen.m4 \
+ m4/ax_valgrind_check.m4 \
+ m4/pkg.m4 \
+ $(DIST_ARCHIVES)
### Add ax_* rules ###
# ax_code_coverage