aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Tricca <philip.b.tricca@intel.com>2018-02-20 14:56:05 -0800
committerPhilip Tricca <philip.b.tricca@intel.com>2018-02-23 12:22:56 -0800
commit0b842faf5b56a0966eea794dcd55768cacd16b85 (patch)
treeeefff55de7048c02dbbe53a04b67f9cc5ca94663 /Makefile.am
parentcdb027c42f31a2c058c1adbeb351d201edab2444 (diff)
downloadtpm2-tss-0b842faf5b56a0966eea794dcd55768cacd16b85.tar.gz
libtcti-socket: Cleanup PlatformCommand and use 'read' not 'recv'.
This function did some fancy stuff to marshal small integers into UINT32s. It was only accepting UINT8s via the input parameter and then storing them into the 3rd byte of a 4 byte buffer. This is what the type marshalling library is for so we replace this with much less clever and much more readable code. This patch also replaces the use of 'recv' with 'read' since we weren't doing anything with the flags / socket specific. Signed-off-by: Philip Tricca <philip.b.tricca@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4a4931dd..54754c44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,7 +168,7 @@ test_unit_tcti_device_SOURCES = test/unit/tcti-device.c tcti/tcti_device.c log/l
test_unit_tcti_socket_CFLAGS = $(CMOCKA_CFLAGS) $(AM_CFLAGS) $(URIPARSER_CFLAGS)
test_unit_tcti_socket_LDADD = $(CMOCKA_LIBS) $(libmarshal) $(URIPARSER_LIBS) $(libutil)
-test_unit_tcti_socket_LDFLAGS = -Wl,--wrap=connect,--wrap=recv,--wrap=select,--wrap=write
+test_unit_tcti_socket_LDFLAGS = -Wl,--wrap=connect,--wrap=recv,--wrap=read,--wrap=select,--wrap=write
test_unit_tcti_socket_SOURCES = tcti/platformcommand.c tcti/tcti_socket.c \
tcti/sockets.c tcti/sockets.h test/unit/tcti-socket.c