aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Tricca <philip.b.tricca@intel.com>2017-12-04 21:15:48 -0800
committerPhilip Tricca <philip.b.tricca@intel.com>2017-12-05 13:55:17 -0500
commit313cea8ad79be86f116cc8eacb07c491ec683a7b (patch)
tree23c2c6093462d0cff68a1ebee10ebe6241af9640 /Makefile.am
parentbf9b61261137a7d356c1966f1f91d2fd114e89d6 (diff)
downloadtpm2-tss-313cea8ad79be86f116cc8eacb07c491ec683a7b.tar.gz
build: Add libmu as a dependency of libtcti-socket.
This seems to have just been an oversight. Signed-off-by: Philip Tricca <philip.b.tricca@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b7d841f7..732504ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -217,6 +217,7 @@ tcti_libtcti_socket_la_CFLAGS = $(AM_CFLAGS)
if HAVE_LD_VERSION_SCRIPT
tcti_libtcti_socket_la_LDFLAGS = -Wl,--version-script=$(srcdir)/tcti/tcti_socket.map
endif # HAVE_LD_VERSION_SCRIPT
+tcti_libtcti_socket_la_LIBADD = $(libmarshal)
tcti_libtcti_socket_la_SOURCES = tcti/platformcommand.c tcti/tcti_socket.c \
tcti/tcti.c tcti/tcti.h tcti/sockets.c tcti/sockets.h \
common/debug.c common/debug.h tcti/logging.h