aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTadeusz Struk <tadeusz.struk@intel.com>2018-02-01 14:18:23 -0800
committerPhilip Tricca <philip.b.tricca@intel.com>2018-02-02 17:21:11 -0800
commit7c72dd4829ada3b4030427cdb2a0ed5c61ca7e0b (patch)
treeeef5e189d2f4cc4fed21761ad16e3290b08b991a /Makefile.am
parent23d8635972b3ad1a1cfb3be94aeeee16cd4ee9d4 (diff)
downloadtpm2-tss-7c72dd4829ada3b4030427cdb2a0ed5c61ca7e0b.tar.gz
test: add test for TPM2_CreateLoaded command
Signed-off-by: Tadeusz Struk <tadeusz.struk@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 23921d0d..70f4aa2b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,7 @@ TESTS_INTEGRATION = \
test/integration/tpm-properties.int \
test/integration/system-api.int \
test/integration/policy-template.int \
+ test/integration/create-loaded.int \
test/tpmclient/tpmclient.int
endif #SIMULATOR_BIN
@@ -336,6 +337,11 @@ test_integration_policy_template_int_LDADD = $(TESTS_LDADD)
test_integration_policy_template_int_SOURCES = test/integration/main.c log/log.h log/log.c \
test/integration/policy-template.int.c
+test_integration_create_loaded_int_CFLAGS = $(AM_CFLAGS) $(TESTS_CFLAGS)
+test_integration_create_loaded_int_LDADD = $(TESTS_LDADD)
+test_integration_create_loaded_int_SOURCES = test/integration/main.c log/log.h log/log.c \
+ test/integration/create-loaded.int.c
+
TESTS_CFLAGS = $(LIBCRYPTO_CFLAGS)
TESTS_LDADD = $(noinst_LTLIBRARIES) $(lib_LTLIBRARIES) $(LIBCRYPTO_LIBS)