aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Tricca <philip.b.tricca@intel.com>2018-03-10 18:28:25 -0800
committerPhilip Tricca <philip.b.tricca@intel.com>2018-03-14 17:29:15 -0700
commita7c51ce296231bda2f8137a2d02a1557dac15caa (patch)
treeee3b3b3da8210dec2b4dee80d7bffa7b0ef18d9d /Makefile.am
parent5f0ab55d4e46077cb8f0c53a76c5ebd15a088d26 (diff)
downloadtpm2-tss-a7c51ce296231bda2f8137a2d02a1557dac15caa.tar.gz
build: Move logging code and tss2_endian.h to $(srcdir)/src/util
Some fixups to filepaths in the automake files was necessary. Also a bunch of the integration tests were building the logging implementation in to the test executable. This was an opportunity to have them just use the implementation from the utility library. Signed-off-by: Philip Tricca <philip.b.tricca@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8186f404..fc0cc2bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,7 +94,8 @@ tss2_HEADERS = \
libutil = libutil.la
noinst_LTLIBRARIES += $(libutil)
libutil_la_CFLAGS = $(AM_CFLAGS)
-libutil_la_SOURCES = log/log.c log/log.h src/tss2-tcti/tcti.c src/tss2-tcti/tcti.h
+libutil_la_SOURCES = src/util/log.c src/util/log.h src/util/tss2_endian.h \
+ src/tss2-tcti/tcti.c src/tss2-tcti/tcti.h
### TCG TSS Marshaling/Unmarshalling spec library ###
libtss2_mu = src/tss2-mu/libtss2-mu.la
@@ -146,7 +147,7 @@ lib_LTLIBRARIES += $(libtss2_sys)
nodist_pkgconfig_DATA += lib/tss2-sys.pc
EXTRA_DIST += lib/tss2-sys.pc.in
-src_tss2_sys_libtss2_sys_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/src/tss2-mu -I$(srcdir)/src/tss2-sys/include
+src_tss2_sys_libtss2_sys_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/src/tss2-sys/include
src_tss2_sys_libtss2_sys_la_LIBADD = $(libtss2_mu)
src_tss2_sys_libtss2_sys_la_SOURCES = $(TSS2_SYS_SRC)