aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTadeusz Struk <tadeusz.struk@intel.com>2018-10-23 16:04:25 -0700
committerTadeusz Struk <tadeusz.struk@intel.com>2018-10-24 09:11:27 -0700
commita5ff71abeda9a5aea269812de32afb79ef3fcb4d (patch)
tree18337e6f285bb52e2dc8b3480a6ac3dce92f1862 /configure.ac
parent29f7eeb377b451bea8d89ecc607c0e47204c5517 (diff)
downloadtpm2-tss-a5ff71abeda9a5aea269812de32afb79ef3fcb4d.tar.gz
configure.ac: switch default ESAPI crypto backend to openSSL
Switch the default ESAPI crypto backend to openSSL. This should also fix the problem with forcing applications to link against libgcrypt. Fixes: #1169 Signed-off-by: Tadeusz Struk <tadeusz.struk@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c42b487f..993e858e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,9 +77,9 @@ AS_IF([test "x$enable_tcti_device_async" = "xyes"],
AC_ARG_WITH([crypto],
[AS_HELP_STRING([--with-crypto={gcrypt,ossl}],
- [sets the ESAPI crypto backend (default is gcrypt)])],
+ [sets the ESAPI crypto backend (default is OpenSSL)])],
[],
- [with_crypto=gcrypt])
+ [with_crypto=ossl])
AM_CONDITIONAL(ESYS_OSSL, test "x$with_crypto" = "xossl")
AM_CONDITIONAL(ESYS_GCRYPT, test "x$with_crypto" = "xgcrypt")
@@ -311,4 +311,5 @@ AC_MSG_RESULT([
maxloglevel: $with_maxloglevel
doxygen: $DX_FLAG_doc $enable_doxygen_doc
tcti-device-async: $enable_tcti_device_async
+ crypto backend: $with_crypto
])