aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Witschel <diabonas@gmx.de>2019-12-20 11:39:06 +0100
committerTadeusz Struk <tadeusz.struk@intel.com>2020-01-03 10:46:13 -0800
commitde73fda34be4bda8546943bc3e69207dd0ff58b0 (patch)
tree045d36d17104cd494a3243e103ee941b74790644 /configure.ac
parentf47fe60cfe211295c8a7a7f75cfd7bed9465f863 (diff)
downloadtpm2-tss-de73fda34be4bda8546943bc3e69207dd0ff58b0.tar.gz
FAPI: use only tmpfiles.d to create keystore and eventlog directory
Using chown in make install is problematic because the user and group are not guaranteed to exist and this approach does not work for packaging. Use the already existing tmpfiles.d configuration to adjust the owner and mode instead. On the other hand, installing files to runstatedir does not make sense since this directory might be cleaned on reboot. Since this directory is already created by tmpfiles.d, remove the unnecessary installation instruction. Signed-off-by: Jonas Witschel <diabonas@gmx.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 383f14d5..9aa00c1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ AC_SUBST(userstatedir, $with_userstatedir)
AC_ARG_WITH([tmpfilesdir],
[AS_HELP_STRING([--with-tmpfilesdir=<dir>],
- [sets the tpmfiles.d directory (default is "${sysconfdir}/tmpfiles.d")])],,
+ [sets the tmpfiles.d directory (default is "${sysconfdir}/tmpfiles.d")])],,
[with_tmpfilesdir="${sysconfdir}/tmpfiles.d"])
AC_SUBST(tmpfilesdir, $with_tmpfilesdir)