aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Huewe <peterhuewe@gmx.de>2019-02-19 22:56:21 +0100
committerTadeusz Struk <tadeusz.struk@intel.com>2019-02-19 16:51:08 -0800
commitf59aee3ad834440d55fb1522c75deb73102c5f8e (patch)
treebf5212a3041dd51e3834e47ac8c6858addfcc0d1 /configure.ac
parented92b832b85d94744e2d713473d560c22647015b (diff)
downloadtpm2-tss-f59aee3ad834440d55fb1522c75deb73102c5f8e.tar.gz
Add valgrind for integration and unit tests
By adding these two autoconf-archive macros we can easily enable valgrind checks for our unit and integration tests. If valgrind is installed on the system during configure, a few new make targets are added automatically make check-valgrind make check-valgrind-<toolname> Normal testflow is not altered by these new targets. Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a6c49d5..d9695318 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,6 +195,8 @@ AS_IF([test "x$enable_integration" = "xyes"],
AC_SUBST([ENABLE_INTEGRATION], [$enable_integration])])
AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"])
+AX_VALGRIND_CHECK
+
gl_LD_VERSION_SCRIPT
AC_ARG_WITH([maxloglevel],