aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Fuchs <andreas.fuchs@sit.fraunhofer.de>2018-08-29 13:30:35 +0200
committerPhilip Tricca <philip.b.tricca@intel.com>2018-08-29 07:30:09 -0700
commitfefb6b049229c16ed139d4ebad404187c3262a5b (patch)
tree0a0390546f6abe1020593065c71d8abcdaad3e33 /configure.ac
parent960359381d8b68a79d82879a2f8c3733ac3f8ef8 (diff)
downloadtpm2-tss-fefb6b049229c16ed139d4ebad404187c3262a5b.tar.gz
ESYS: Correct default tcti handling
Pass the default tcti module and config as strings into C. Signed-off-by: Andreas Fuchs <andreas.fuchs@sit.fraunhofer.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dc33d0e1..6fade537 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,7 +118,7 @@ AC_ARG_WITH([tctidefaultmodule],
[AS_HELP_STRING([--with-tctidefaultmodule],
[The default TCTI module for ESAPI. (Default: libtss2-tcti-default.so])],
[AC_DEFINE_UNQUOTED([ESYS_TCTI_DEFAULT_MODULE],
- [$with_tctidefaultmodule],
+ ["$with_tctidefaultmodule"],
["The default TCTI library file"])],
[])
@@ -126,7 +126,7 @@ AC_ARG_WITH([tctidefaultconfig],
[AS_HELP_STRING([--with-tctidefaultconfig],
[The default tcti module's configuration.])],
[AC_DEFINE_UNQUOTED([ESYS_TCTI_DEFAULT_CONFIG],
- [$with_tctidefaultconfig],
+ ["$with_tctidefaultconfig"],
["The default TCTIs configuration string"])],
[])