aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJavi Merino <javi.merino@arm.com>2015-12-07 15:19:18 +0000
committerJavi Merino <javi.merino@arm.com>2015-12-07 15:26:33 +0000
commit88dd0cfcaa66600fb70b966191be34d4cd47a160 (patch)
treece8d554431a138ef24e248e68ceef0e215456373 /setup.py
parent841145edfad41cf9c26bc0b29474a7660d0f13c8 (diff)
downloadtrappy-88dd0cfcaa66600fb70b966191be34d4cd47a160.tar.gz
setup: install pyparsing and numpy when installing trappy
trappy.stats.grammar needs pyparsing and numpy. Explicitly install them when installing trappy instead of relying on them being installed indirectly through other dependencies.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a0e4081..9db1d06 100644
--- a/setup.py
+++ b/setup.py
@@ -29,6 +29,8 @@ based on the underlying FTrace data.
"""
REQUIRES = [
"matplotlib>=1.3.1",
+ "numpy",
+ "pyparsing",
"pandas>=0.13.1",
"ipython>=3.0.0",
"jupyter>=1.0.0",