aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKapileshwar Singh <kapileshwar.singh@arm.com>2015-09-02 17:55:42 +0100
committerKapileshwar Singh <kapileshwar.singh@arm.com>2015-09-03 16:25:23 +0100
commit9c4a49fecccda25b9785ff83d9608ecb36ce46fa (patch)
treedee0662fa117883ed186e8848787711c533c3fda /setup.py
parent84cbf3b8bd8861743cdd63339b746d3e7049e51d (diff)
downloadtrappy-9c4a49fecccda25b9785ff83d9608ecb36ce46fa.tar.gz
setup: Add setup.py
Signed-off-by: Kapileshwar Singh <kapileshwar.singh@arm.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py60
1 files changed, 60 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f82e99d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,60 @@
+#!/usr/bin/env python
+# Copyright 2015-2015 ARM Limited
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+from setuptools import setup, find_packages
+
+
+VERSION = "1.0.0"
+
+LONG_DESCRIPTION = """TRAPpy is a framework written in python for
+analysing and plotting FTrace data by converting it into standardised
+PANDAS DataFrames (tabular times series data representation).The goal is to
+allow developers easy and systematic access to FTrace data and leverage
+the flexibility of PANDAS for the analysis.
+
+TRAPpy also provides functionality to build complex statistical analysis
+based on the underlying FTrace data.
+"""
+REQUIRES = [
+ "matplotlib>=1.3.1",
+ "pandas>=0.13.1",
+ "ipython>=3.0.0",
+ "jupyter>=1.0.0",
+]
+
+setup(name='TRAPpy',
+ version=VERSION,
+ license="Apache v2",
+ author="ARM-TRAPPY",
+ author_email="trappy@arm.com",
+ description="Trace Analysis and Plotting",
+ long_description=LONG_DESCRIPTION,
+ url="http://arm-software.github.io/trappy",
+ packages=find_packages(),
+ include_package_data=True,
+ scripts=["scripts/publish_interactive_plots.py"],
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Environment :: Console",
+ "License :: OSI Approved :: Apache Software License",
+ "Operating System :: POSIX :: Linux",
+ "Programming Language :: Python :: 2.7",
+ # As we depend on trace data from the Linux Kernel/FTrace
+ "Topic :: System :: Operating System Kernels :: Linux",
+ "Topic :: Scientific/Engineering :: Visualization"
+ ],
+ install_requires=REQUIRES
+ )