aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Weinrank <weinrank@fh-muenster.de>2017-09-19 15:51:04 +0200
committerFelix Weinrank <weinrank@fh-muenster.de>2017-09-19 15:51:04 +0200
commit310e7f586480345409b9bd88832632a9f3d69536 (patch)
tree7964b741c72c7ba6561ca0670fbff040f206efc6 /CMakeLists.txt
parente1614592bed1b78c8da111468dd09beb9a4e5d76 (diff)
downloadusrsctp-310e7f586480345409b9bd88832632a9f3d69536.tar.gz
CMake cleanup : sync options with configure script
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt40
1 files changed, 0 insertions, 40 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f718335..95623759 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,46 +67,6 @@ if (INET6)
add_definitions(-DINET6)
endif ()
-option(SCTP_SIMPLE_ALLOCATOR " " 1)
-if (SCTP_SIMPLE_ALLOCATOR)
- add_definitions(-DSCTP_SIMPLE_ALLOCATOR)
-endif ()
-
-option(SCTP_PROCESS_LEVEL_LOCKS " " 1)
-if (SCTP_PROCESS_LEVEL_LOCKS)
- add_definitions(-DSCTP_PROCESS_LEVEL_LOCKS)
-endif ()
-
-option(SCTP_WITH_NO_CSUM "Disable SCTP checksum" 0)
-if (SCTP_WITH_NO_CSUM)
- add_definitions(-DSCTP_WITH_NO_CSUM)
-endif ()
-
-option(SCTP_MBUF_LOGGING " " 0)
-if (SCTP_MBUF_LOGGING)
- add_definitions(-DSCTP_MBUF_LOGGING)
-endif ()
-
-option(SCTP_PACKET_LOGGING " " 0)
-if (SCTP_PACKET_LOGGING)
- add_definitions(-DSCTP_PACKET_LOGGING)
-endif ()
-
-option(SCTP_SO_LOCK_TESTING " " 0)
-if (SCTP_SO_LOCK_TESTING)
- add_definitions(-DSCTP_SO_LOCK_TESTING)
-endif ()
-
-option(SCTP_EMBEDDED_V6_SCOPE " " 0)
-if (SCTP_EMBEDDED_V6_SCOPE)
- add_definitions(-DSCTP_EMBEDDED_V6_SCOPE)
-endif ()
-
-option(SCTP_KAME " " 0)
-if (SCTP_KAME)
- add_definitions(-DSCTP_KAME)
-endif ()
-
option(WERROR "Warning as error" 1)
option(LINK_PROGRAMS_STATIC "Link example programs static" 0)