aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authort00fcxen <t00fcxen@9df1edf5-d72c-5b5f-11c0-5f5209eb73f7>2013-12-27 19:21:25 +0000
committert00fcxen <t00fcxen@9df1edf5-d72c-5b5f-11c0-5f5209eb73f7>2013-12-27 19:21:25 +0000
commit652291c7cd054f8f3ad22022ee1135e718bb0127 (patch)
treeb1a029fe415f20d710cf6528c3b9cb47fa7131ed /configure.ac
parent919adcea03640b02d1516307fb188512d390f49f (diff)
downloadusrsctp-652291c7cd054f8f3ad22022ee1135e718bb0127.tar.gz
Improve support of NetBSD and OpenBSD.
Patches were suggested by Luca Bayer, some of them have been modified.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 66a59a1c..ba48f664 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,9 +42,9 @@ darwin*)
CFLAGS="$CFLAGS -pedantic -Wall -std=c99 -Werror -D__APPLE_USE_RFC_2292"
LIBCFLAGS="$LIBCFLAGS -U__APPLE__ -D__Userspace_os_Darwin"
;;
-linux*)
- CFLAGS="$CFLAGS -pedantic -Wall -Werror -pthread -D_GNU_SOURCE"
- LIBCFLAGS="$LIBCFLAGS -D__Userspace_os_Linux"
+dragonfly*)
+ CFLAGS="$CFLAGS -pedantic -Wall -Werror -pthread"
+ LIBCFLAGS="$LIBCFLAGS -U__DragonFly__ -D__Userspace_os_DragonFly"
;;
freebsd*)
CFLAGS="$CFLAGS -pedantic -Wall -Werror -pthread"
@@ -53,6 +53,14 @@ freebsd*)
fi
LIBCFLAGS="$LIBCFLAGS -U__FreeBSD__ -D__Userspace_os_FreeBSD"
;;
+linux*)
+ CFLAGS="$CFLAGS -pedantic -Wall -Werror -pthread -D_GNU_SOURCE"
+ LIBCFLAGS="$LIBCFLAGS -D__Userspace_os_Linux"
+ ;;
+netbsd*)
+ CFLAGS="$CFLAGS -pedantic -Wall -Werror -pthread"
+ LIBCFLAGS="$LIBCFLAGS -U__NetBSD__ -D__Userspace_os_NetBSD"
+ ;;
openbsd*)
CFLAGS="$CFLAGS -pedantic -Wall -Werror -pthread"
LIBCFLAGS="$LIBCFLAGS -U__OpenBSD__ -D__Userspace_os_OpenBSD"