aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2019-11-08 23:41:30 +0530
committerMichael Tüxen <tuexen@fh-muenster.de>2019-11-08 19:11:30 +0100
commit05cd8b58849f0629639969feabac4fe097b21806 (patch)
treec8deddba880b3d83d2b373c14263761e38f23452 /meson.build
parent48e52cec86aadbe1e1eccc29a13047d6f99c9c15 (diff)
downloadusrsctp-05cd8b58849f0629639969feabac4fe097b21806.tar.gz
meson: Fixes needed to build on Android (#402)
* meson: add support for android/ios host_system * build: include ifaddrs.c definition for android
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 763edf93..71850940 100644
--- a/meson.build
+++ b/meson.build
@@ -56,7 +56,7 @@ add_project_arguments([
# OS-specific settings
system = host_machine.system()
-if system == 'linux'
+if ['linux', 'android'].contains(system)
add_project_arguments([
'-D__Userspace_os_Linux',
'-D_GNU_SOURCE',
@@ -68,7 +68,7 @@ elif system == 'freebsd'
] + compiler.get_supported_arguments([
'-Wno-address-of-packed-member',
]), language: 'c')
-elif system == 'darwin'
+elif ['darwin', 'ios'].contains(system)
add_project_arguments([
'-D__Userspace_os_Darwin',
'-U__APPLE__',