aboutsummaryrefslogtreecommitdiff
path: root/programs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'programs/CMakeLists.txt')
-rw-r--r--programs/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/programs/CMakeLists.txt b/programs/CMakeLists.txt
index 45a661ff..eeebee91 100644
--- a/programs/CMakeLists.txt
+++ b/programs/CMakeLists.txt
@@ -190,9 +190,9 @@ FOREACH (source_file ${check_PROGRAMS})
IF ("x${CMAKE_C_COMPILER_ID}" STREQUAL "xMSVC")
IF (CMAKE_C_FLAGS MATCHES "/W[0-4]")
- STRING(REGEX REPLACE "/W[0-4]" "/W4" CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
+ STRING(REGEX REPLACE "/W[0-4]" "/W3" CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
ELSE ()
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /W4")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /W3")
ENDIF ()
IF (WERROR)