aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2012-10-22 22:11:27 -0700
committerChad Versace <chad.versace@linux.intel.com>2012-11-14 20:50:11 -0800
commit0ea26bd7735b3739b6543fb7e6cc66a261acc305 (patch)
tree05e27c3727505d02ceb26b4770334f01fb3e4316 /CMakeLists.txt
parent27bc14a4de4b05d6836a17dc794d2bf71e265874 (diff)
downloadwaffle-0ea26bd7735b3739b6543fb7e6cc66a261acc305.tar.gz
man,cmake: Generate html documentation
Add new cmake option `waffle_build_htmldocs`. Default is off. Add some new cmake rules and an html.xsl to generate the docs. The output directory is /doc/html. Install the html docs to CMAKE_INSTALL_DOCDIR/html. All citations, even those to GLX and EGL functions, have correct urls. Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f62ad10..970faf8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,9 +88,10 @@ find_package(PkgConfig)
option(waffle_build_tests "Build tests" ON)
-# Most users don't have the necessary tools installed to build manpages from
+# Most users don't have the necessary tools installed to build from
# Docbook sources, so require users to explicitly enable building them.
option(waffle_build_manpages "Build manpages" OFF)
+option(waffle_build_htmldoc "Build html documentation" OFF)
option(waffle_build_examples "Build examples" ON)
@@ -272,10 +273,7 @@ add_subdirectory(doc)
add_subdirectory(pkg)
add_subdirectory(src)
add_subdirectory(include)
-
-if(waffle_build_manpages)
- add_subdirectory(man)
-endif()
+add_subdirectory(man)
if(waffle_build_tests)
add_subdirectory(tests)
@@ -380,7 +378,7 @@ message(" cc: ${CMAKE_C_COMPILER}")
message(" CFLAGS_base: ${CMAKE_C_FLAGS}")
message(" CFLAGS_debug: ${CMAKE_C_FLAGS_DEBUG}")
message(" CFLAGS_release: ${CMAKE_C_FLAGS_RELEASE}")
-if(waffle_build_manpages)
+if(waffle_build_manpages OR waffle_build_htmldocs)
message(" xsltproc: ${waffle_xsltproc}")
endif()
message("")