aboutsummaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index b89fde3..a2d46e6 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,7 +1,14 @@
-install(FILES "${CMAKE_SOURCE_DIR}/README.txt"
- "${CMAKE_SOURCE_DIR}/LICENSE.txt"
- DESTINATION "${CMAKE_INSTALL_DOCDIR}")
+install(
+ FILES
+ "${CMAKE_SOURCE_DIR}/README.txt"
+ "${CMAKE_SOURCE_DIR}/LICENSE.txt"
+ DESTINATION "${CMAKE_INSTALL_DOCDIR}"
+ COMPONENT coredocs
+ )
-install(DIRECTORY "${CMAKE_SOURCE_DIR}/doc/release-notes"
- DESTINATION "${CMAKE_INSTALL_DOCDIR}"
- FILES_MATCHING PATTERN "waffle-${waffle_major_version}.${waffle_minor_version}.*.txt")
+install(
+ DIRECTORY "${CMAKE_SOURCE_DIR}/doc/release-notes"
+ DESTINATION "${CMAKE_INSTALL_DOCDIR}"
+ COMPONENT releasenotes
+ FILES_MATCHING PATTERN "waffle-${waffle_major_version}.${waffle_minor_version}.*.txt"
+ )