aboutsummaryrefslogtreecommitdiff
path: root/pywalt/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'pywalt/setup.py')
-rwxr-xr-xpywalt/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/pywalt/setup.py b/pywalt/setup.py
new file mode 100755
index 0000000..e7e1acd
--- /dev/null
+++ b/pywalt/setup.py
@@ -0,0 +1,17 @@
+#!/usr/bin/env python
+
+from setuptools import setup, find_packages
+
+setup(
+ name='pywalt',
+ entry_points={
+ 'console_scripts': (
+ 'walt = pywalt.walt:main',
+ ),
+ },
+ install_requires=['pyserial'],
+ packages=find_packages(),
+ description='WALT Latency Timer',
+ license='Apache 2.0',
+ url='https://github.com/google/walt',
+)