aboutsummaryrefslogtreecommitdiff
path: root/third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Hung <hunga@google.com>2020-10-29 02:09:57 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2020-10-29 02:09:57 +0000
commit6305a290a0e261dbf61354f298a799297de54360 (patch)
tree35d73359fd09cc16d1fbb857909581bad75b765e /third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt
parentbdcf7c15937fa6f88b52f091024bd667d6b2b302 (diff)
parentb02c729712188d3420b78a1bbb1b779544bd4427 (diff)
downloadwebrtc-6305a290a0e261dbf61354f298a799297de54360.tar.gz
Merge "Import abseil-cpp to third_party" am: aa2897cdcb am: 2cc1e455f9 am: 4211622fc5 am: b02c729712
Original change: https://android-review.googlesource.com/c/platform/external/webrtc/+/1477956 Change-Id: I2157494054f0fdd15375163dda6ee668e2b90f0b
Diffstat (limited to 'third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt')
-rw-r--r--third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt b/third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt
new file mode 100644
index 0000000000..06b797e9ed
--- /dev/null
+++ b/third_party/abseil-cpp/CMake/install_test_project/CMakeLists.txt
@@ -0,0 +1,27 @@
+#
+# Copyright 2019 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# A simple CMakeLists.txt for testing cmake installation
+
+cmake_minimum_required(VERSION 3.5)
+project(absl_cmake_testing CXX)
+
+set(CMAKE_CXX_STANDARD 11)
+
+add_executable(simple simple.cc)
+
+find_package(absl REQUIRED)
+
+target_link_libraries(simple absl::strings)