aboutsummaryrefslogtreecommitdiff
path: root/third_party/abseil-cpp/absl/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Hung <hunga@google.com>2020-10-28 22:16:47 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2020-10-28 22:16:47 +0000
commitaa2897cdcbeca872034af249eee55672c68d1d81 (patch)
tree35d73359fd09cc16d1fbb857909581bad75b765e /third_party/abseil-cpp/absl/CMakeLists.txt
parent3e1889fd3ec2121f051cded7fa3aaa946b442a6d (diff)
parentbb55342cbca1f67335f46ee07cdc1f30e4c3b140 (diff)
downloadwebrtc-aa2897cdcbeca872034af249eee55672c68d1d81.tar.gz
Merge "Import abseil-cpp to third_party"
Diffstat (limited to 'third_party/abseil-cpp/absl/CMakeLists.txt')
-rw-r--r--third_party/abseil-cpp/absl/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/third_party/abseil-cpp/absl/CMakeLists.txt b/third_party/abseil-cpp/absl/CMakeLists.txt
new file mode 100644
index 0000000000..fbfa7822b5
--- /dev/null
+++ b/third_party/abseil-cpp/absl/CMakeLists.txt
@@ -0,0 +1,37 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_subdirectory(base)
+add_subdirectory(algorithm)
+add_subdirectory(container)
+add_subdirectory(debugging)
+add_subdirectory(flags)
+add_subdirectory(functional)
+add_subdirectory(hash)
+add_subdirectory(memory)
+add_subdirectory(meta)
+add_subdirectory(numeric)
+add_subdirectory(random)
+add_subdirectory(status)
+add_subdirectory(strings)
+add_subdirectory(synchronization)
+add_subdirectory(time)
+add_subdirectory(types)
+add_subdirectory(utility)
+
+if (${ABSL_BUILD_DLL})
+ absl_make_dll()
+endif()