aboutsummaryrefslogtreecommitdiff
path: root/third_party/abseil-cpp/absl/meta/CMakeLists.txt
diff options
context:
space:
mode:
authorandroid-build-team Robot <android-build-team-robot@google.com>2021-06-17 19:05:31 +0000
committerandroid-build-team Robot <android-build-team-robot@google.com>2021-06-17 19:05:31 +0000
commit7c3753117f7d9906f1c0372f9ad6c1b69d1734e0 (patch)
treecb306ffb64819f95c080c3cb6bfcdfb45a7b3a76 /third_party/abseil-cpp/absl/meta/CMakeLists.txt
parent661e84967bb2600427cb65715caeeba112b94244 (diff)
parentb7c9dafe99969a4e9d5ffa101bb9a8d6e1df69df (diff)
downloadwebrtc-7c3753117f7d9906f1c0372f9ad6c1b69d1734e0.tar.gz
Change-Id: Id9acacd55a584977d5936f3b731297a27cb30d8a
Diffstat (limited to 'third_party/abseil-cpp/absl/meta/CMakeLists.txt')
-rw-r--r--third_party/abseil-cpp/absl/meta/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/third_party/abseil-cpp/absl/meta/CMakeLists.txt b/third_party/abseil-cpp/absl/meta/CMakeLists.txt
new file mode 100644
index 0000000000..672ead2fd0
--- /dev/null
+++ b/third_party/abseil-cpp/absl/meta/CMakeLists.txt
@@ -0,0 +1,50 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+absl_cc_library(
+ NAME
+ type_traits
+ HDRS
+ "type_traits.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ DEPS
+ absl::config
+ PUBLIC
+)
+
+absl_cc_test(
+ NAME
+ type_traits_test
+ SRCS
+ "type_traits_test.cc"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
+ absl::type_traits
+ gmock_main
+)
+
+# component target
+absl_cc_library(
+ NAME
+ meta
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ DEPS
+ absl::type_traits
+ PUBLIC
+)